We’re pleased to inform you that the issue has been fully resolved and all services are now operating normally.
We appreciate your patience and understanding during this time. If you have any questions or need further assistance, please feel free to reach out to us.
Regards, TalkEHR Support
Posted Jun 20, 2025 - 18:07 UTC
Monitoring
We are pleased to inform you that the internet outage has been successfully resolved. All services are now fully operational, and our team is actively monitoring the network to ensure continued stability.
We appreciate your patience and understanding during this time. Should you experience any further issues, please don’t hesitate to reach out to our support team.
Thank you for your continued trust.
Regards, TalkEHR Support Team
Posted Jun 20, 2025 - 17:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 20, 2025 - 15:42 UTC
Identified
We are currently experiencing intermittent service disruptions and slower-than-usual system performance due to widespread internet connectivity issues across the United States, which are impacting multiple network providers.
Our team is actively monitoring the situation and working with upstream partners to mitigate the impact. While core systems remain operational, you may notice occasional delays or brief interruptions in service.
We will continue to provide updates as more information becomes available.
Thank you for your patience and understanding.
Posted Jun 20, 2025 - 15:37 UTC
Update
We are continuing to investigate this issue.
Posted Jun 20, 2025 - 15:34 UTC
Update
We are continuing to investigate this issue.
Posted Jun 20, 2025 - 14:55 UTC
Investigating
Dear Clients,
We are currently experiencing network-related issues that are preventing users from logging into the TalkEHR. Our technical team is actively working to resolve the problem as quickly as possible.
We apologize for the inconvenience and appreciate your patience and understanding.